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» Practical steps for Big Live Data
» Conclusions

» Next: DATA EVOLUTION ..



Evolution and Durability

» At first sight these look like “complementary” notions
» Like position vs momentum, truth vs clarity

» For the best sorts of data, both are needed
» What is the value¢ What was it before?¢ Why changed?

» Patient records, bank accounts, scientific results, guidelines

» Copies, models and hearsay are likely to be wrong

» Insist on correctness rather than availability

» This talk is about new approach to DBMS implementation
» Taking account of changes since 1970s
» Proof of Concept in StrongDBMS and PyrrhoDB (in progress)

» Full references in notes pages of these slides and at end

» Data evolves



Evolving data

» Always the focus of Relational DBMS
» Customer accounts, scientific results
» Shared access and long-term durabllity
» Standards development continues today
» With a cost: durability, backward compatibility

» Trend to use universal types, time,
locale

» Big Data focus on metadata and
semantics

» Databases need to include such aspects

» Some use cases



Big data: serious use cases

» Raw scientific and administrative data
» Carried on the public web, often real time

» DNA signatures of new Covid variants

» Data from tsunami observatories

» Treatment history of seriously ill patients

» Fluid flow computations

» Steel plates used in a tower block, ship

» Available intensive care equipment

» A particular sensor in the Infernet of Things

» We would like..



A wish list for SQL support

» Search current data from named servers
» Search by metadata (RDF, provenance)
» Results include provenance and ownership

» Remote updates (if permitted) handled by
owner

» Minimise data fraffic, load on remofte servers

» Allow for tfransformation during retrieval
» With inverses for updates if permitted

» Changes securely fransacted and durably
recorded

» DBMS need to evolve



DBMS need to evolve too

» Durable storage is for what we want to keep
» Don’t use it for infermediate results or indexes
» Commits are added o the transaction log

» Nothing else is ever written to durable storage
» Make better use of the Infernet service
» |dentify data ownership, provenance, audifing
» Derive results from sources, not clones/copies
» Data is more durable than systems, devices
» Legacy vs. history, alter vs. replace
» Access data at its source: don’'t use ETL

» SQL needs to evolve



Better standards for DBMS

On the next few slides we discuss the following ideas
» Validate transaction serialization

» Support more of SQL standard (ISO 9075)

» Including side effects in atomicity rule
» Constraints, cascades, triggers

» Definer’s role for each step of execution

» A novel proposal to help apply SQL's security model
» Generalize the data type system
» Support metadata directly in SQL

» For all database objects including subtypes
» Example: Specify inverse and monotonic functions

» Allow remote access to databases in SQL
» Include remote tables in tfransaction control
10

» Serialized transactions



Serialized Transactions

» The goal of any DBMS
» Should be to serialize transactions
» Many users making changes
» Could lead to chaos
» Transactional systems avoid this

» cost of ~9% performance reported on some commercial systems
» Alas: Business customers don't think this is worthwhile ®

» Isolation levels defined in ISO standard
» READ_UNCOMMITTED, READ_COMMITIED, REPEATABLE_READ, SERIALIZABLE

» Textbooks say serializable is needed
» But immediately settle for much less ®
» A transaction log (StrongDBMS, Pyrrho) ©

» Even better: Guarantees isolation by preventing conflicts
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» What are conflictse



Managing transaction conflict

» Changes to the same database object

» For tables we have fine granularity:

» Report conflict if any columns read have
been updated by another transaction

» If only specific rows read, limit the above
checks to these

» In 2021 PyrrhoDB demo with 50 clerks

» Showed a high-concurrency version of TPC-C

» The algorithm was re-implemented this year
using two simple trees for columns and rows
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» Side effects


https://youtu.be/0YaU59LvgLs
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Side effects and atomicity
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Few DBMS implement this rule of SQL (sec 4.41)
Consequential actions are part of fransaction

Cascades for DROP, DELETE, UPDATE constraints

» DEFERRED actions should be done before transaction is
committed

» NO ACTION should be prohibited
Side effects of evaluating constraints

» Condition handlers, exceptions
Anything done by triggers

Recall that changes during a transaction are not visible
to other users

» But may throw exceptions that abort the transaction
All become visible on COMMIT

» Next: The Security model



The SQL security model

» Most businesses use app-level security
» Many have tried to implement roles
» SQL mandates Users and Roles

» Many kinds of privileges on DB objects
» But few suggestion on how to do this well

» We offer some suggestions here
» We assume operating system is secure

» Authenticates users (DBMS shouldn’t)
» And secure communications over TCP
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» What we would like



From user model to roles

» US Department of Defense Orange Book
» Focus on user responsibility and security
» DBMS should focus on database objects

» Roles offer privileges on objects

» And Users are allowed to use Roles
» E.g. Access to all Sales or Finance tools, data

» Some suggestions:

» User can use only one role at a time
» Means that people can substitute for sick colleague

» Auditing of all actions logs user and role
» Facilitates investigation, remedies for bad actions

» Avoid external routines: ensure DBMS in control
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» Use Definer’s role



Definer’s role
» Roles use different jargon and
conventions
» Naming of objects can depend on roles
» Focus on creators of database objects
» Methods, tables, constraints, triggers
» They will use conventions of their role
» The finished object is then grantable
» Such code will work best in that role

» Other staff might need to be given access
» But surely not to all the underlying detaill
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» Role for Execution



Standard implementation

» Evaluation of expressions uses roles
» Object constraints and triggers
» Invoked in background, use definer role

» The SQL standard has a context stack

» New stack frames with correct privileges
added on invocation, removed on return

» All data is passed in
» Schema objects use their definer’s role

18

» The data type system



Generalize the type system

» SQL's compatibility rules require equal precision and string length
» Should allow to alter columns to greater length
» Should allow to alter seconds precision etc
» SQL allows the definition of subtypes
» Of user-defined types using UNDER
» Should regard CHAR(5) as a subtype of CHAR
» Should regard a user defined type as a subtype of its underlying type
» Where a user defined type is expected, a subtype can be assigned
» This should be possible for general subtypes
» |t should be possible to have subtypes of predefined types
» And row types
» SQL already allows type predicates (OF) and create table of type
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» Metadata support



Metadata

» Experimental in Pyrrho

» Almost any DDL command can add or
drop metadata

» Currently 24 metadata ids, some with args
» Most affect HTTP service or XML/JSON output

» Some for updatable views etc (e.qQ.
INVERTS)

»If a view V fransforms the value of a column, it
will not be updatable unless there is an inverse
transformation back to the base table’'s format

20

» Big Live data



Big Live Data

» If your data originates in lots of databases

» E.g. Sales or product data from subsidiary
companies

» You could copy the data centrally
» Extract-Transtorm-Load/Big Data
» But, If it keeps changing this is not good
» The durable record should be accessed now

» And leave data where it is evolving (or
curated)

» The available data is provided as a View
» And accessible using HTTP and JSON

21

» Making it easier
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Making big live data easier

Today this needs detailed programming
The following slides offer an SQL solution
Define a VIEW for filtering specific data of interest

vV v v Vv

Allow specific remote users some access to it
» Maybe including updates for known users

» Then aggregations and filters do not need programming

» Just write the SQL you want as if it was a local database

» Many examples in the Pyrrho v7 documentation

Kunde Umsatz kum. U. kum. U. %

Daimler 20000 20000 26% Bosch

Bosch 17000 37000 48% .
Siemens
Siemens 10000 47000 60% stihl
cin
Stihl 2000 25000 71% ; \

VW
VW 62000 80%
Porsche 5000 67000
Migros 4000 71000
ATU 3500 74500
Ford 77700

Daimler

B Porsche
Migros
ATU

Ford

» A derived table

A
A
B
B
B
C
£
C
C




A derived table

Derived = not actually stored centrally
Columns from D's renamed and values probably fransformed

Dl

D2

D3

(Contributors take responsibility for renaming columns and
transforming data to suit us as their schemas will all be different)
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» Next: Contributing DBMS




Defining a contribution

» Probably, each conftributor creates a VIEW
» Out of data from one or more actual tables

CREATE VIEW (A,B,C..) AS ....

A B C

Can identify each contributor in the
result view with a conftributor id CID
and maybe other information
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» Next: The central view



Centrally we then have
» A row type CID,..,A,B,C,..

» The local row contains remote data
» A local table T of contributor details, URLS

T' CiD |... URL
DI URL for D1's data

D2 URL for D2's data

D3 URL for D3’'s data
CREATE VIEW V OF (CID..,A,B,C..) AS GET USING T

» OF clause gives V's row type (specifying column data types)
» Includes all columns from T except the last (the URL)
» The remaining columns specify the data from the remote view

25 A

» Next: Dividing responsibilit |
g resp __);3



Division of responsibility

API

HTTP

- = -
’—— - -

View ééhﬁgm’és’ FTTP access

Change request sent to D1,..

[N N AN D1's API

I D1

No programming!

Views contributed over HTTP transformed
to a common schemad

Contributed data remains under D1's
control — D1 retains responsibility

D1 interprets requests for change and
inverts the transformations if it can

» Next: View-mediated access



What happens with REST

» REST operatfions use standard formats
» For transactions, use RFC7232 (ETags)
» For rows, we use JSON documents

» An item for each column of the row

» Why not add some extra columns for
the Registers in that rowe

» A Register for each occurrence of an
aggregation function in the select list

» With a JSON representation
27

» Next: an example



http://localhost:B1E88/0B/0B select (SUM{E)+CHAR_LENGTH{F))},F from t group by F
TTP POST fDB/DE

select {SUM{E)+CHAR_LEMNGTH{F)),F from t group by F

Returning ETag: "23,-1,1E8"

--» 4 rows

Response ETag: 23,-1,1E48

SQL> select sum(e)+char_length(f),f from ww group by f
| |




Extra Register fields

» The local and remote servers see the same value

expression
» SO the registers are supplied in the left-to-right
ordering
» As a Json document with the following items as
needed:

» The string value accumulated by the function if any
» The value of MAX, MIN, FIRST, LAST, ARRAY

» A document confaining counted values for a multiset
value (can also be used for median, mode etc)

» The value of a typed SUM
» The value of COUNT

> Tk;e)sum of squares (if required for standard deviation
etc

29

» Transactions again



Transactions and REST

» All data needs a single transaction master
» Because of the two-army problem
» Transactions start from one database
» Called the local database (i.e. local server)
» There Is no way to address a remote object directly
» Some fields may come from remote views
» Possibly updatable via REST over HTTP1.1 (safe)
» At most one remote update can be allowed
» When the local commit is called
» Local database locked, validation performed
» The single remote update is done via HTTP1.1
» And then the local commit can complete/unlock
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» Next: Object-Orientation



Conclusions

» This research provides new DBMS tools
» Serialized transactions, RESTViews etc
» In PyrrhoDB v/7.01 currently alpha

» Big Live Data implementation
» Providing better real-time owned behavior

» Optimized for aggregations of remote
VIEWS

» Versioned API for tfransaction-safe apps
» Schema verification (incl RESTView soon)
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» Next: Links



Links

Crowe, M. K., Matalonga, S.: Shareable Data

Structures, on
hitps://aithub.com/MalcolmCrowe/ShareableDatas

fructures

» includes source code for StrongDBMS, PyrrhoV7alpha
and documentation

Crowe, M. K., Laux, F.: Implementing True Serializable
Transactions, Tutorial, DBKDA 2021

» hitps://www.youitube.com/waichev=t4h-zPBPtSw&it=39s
» https://www.iaria.org/conferences2021 /filesDBKDA21/

» Version 6.3: hitps://pyrrhodb.uws.ac.uk
» 50 clerks demo: hitps://youiu.be/0YaUs2Lvals
» Pyrrho blog: hifps://pyrrhodb.blogspof.com

/ \
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https://github.com/MalcolmCrowe/ShareableDataStructures
https://www.youtube.com/watch?v=t4h-zPBPtSw&t=39s
https://www.iaria.org/conferences2021/filesDBKDA21/
https://pyrrhodb.uws.ac.uk/
https://youtu.be/0YaU59LvgLs
https://pyrrhodb.blogspot.com/
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