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This presentation

» Relational Database Management System
(DBMS)

» Pyrrho DBMS Is a research profotype whose
development began in 20056

» Optimistic Execution
» Serialized Transactions

» Shareable Data Structures
» Big Live Data
» Virtual Data Warehousing

» A Versioned RESTful library for web apps
» Application Programming Interface (API)
» Conclusions and future steps

» Next: Serialized transactions



Serialized Transactions

» The goal of any DBMS
» Should be to serialize transactions

» Many users making changes
» Could lead to chaos

» Transactional systems avoid this
» cost of ~9% performance reported on some commercial systems
» Alas: Business customers don't think this is worthwhile ®

» Isolation levels defined in ISO standard
» READ_UNCOMMITTED, READ_COMMITTED, REPEATABLE_READ, SERIALIZABLE

» Textbooks say serializable is needed
» But immediately settle for much less ®

» Pyrrho has always had a transaction log ©
» Even better: Guarantees isolation by preventing conflicts

» Next: Isolation



Transaction Isolation

» Pessimistic: Lock what we plan to change
» All commercial DBMS use this method
» Locking things can get really complicated

» The SERIALIZABLE isolation level results in fransactions being
aborted

» On a step where serialization can no longer be guaranteed

» Optimistic: Validate when we commit

» Then the DBMS must keep transactions isolated

» Different row versions should be private to tfransaction

» Commit will fail only if a conflicting committer gets there first
» Applications can use row versions to ensure serializability

» Solves conflict only with other users of the same application
» Textbooks say optimistic approach should be avoided

» We showed it can be beftter with the right implementation

» Next: StrongDBMS 2017



Fixing isolation: StrongDBMS

» 2017-9: A DBMS also with serialized log

» But very strong transaction isolation

» Outperformed other DBMS In productivity

» Transaction programming Council (TPC)
benchmark test C (Clerks taking phone orders)

» The design has many conflicts for more than 10 clerks
» Throughput continued to increase for > 100 clerks

» But was a very simple DBMS
» Lacking many features that people expect

» We decided o use isolation idea in Pyrrho

» Next: Shareable data structures



Shareable Data Structures

» StrongDB’'s magic ingredient was

» SHAREABLE dafta structures throughout
» Structures are shared but never copied

» Immutable, all fields readonly or final
» A changed object has a new root node

» Shares all the old ones with previous version

» Brings great advantages for fransactions
» Isolation, instant snapshot, just forget on rollback
» But is more complex to program

» Next: Adding a node



When we add a node

KA

{a) the original shared tree,
the position of modification is marked

.// \.

(b) the path to the position of modification is “deshared”,
new nodes are thicker, shared nodes are shaded

9 T. Krijnen, and G. L. T. Meertens, “Making B-Trees work for B”. Amsterdam :
Stichting Mathematisch Centrum, 1982, Technical Report IW 219/83



Tree structures

» BTree<K,V>Is immutable, shareable

» When K and V are shareable

» Two-way traversal

» Uses iImmutable bookmarks
» Database, Transaction all shareable

» Tables, Procedures, Values shareable too
» Transaction Is A private copy

» Changes are prepared for commit step
» Database is bullt from the tx log
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» Next: BTree and transactions



Transaction and B-Tree

M. K. Crowe, S Matalonga: StrongDBMS: Built from Immutable Components
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» Next: Pyrrho outperforms



Now Pyrrho outperforms others

» In 2021, a V/ demo with good productivity
» Productivity increasing up to 50 clerks

» A partial version of Pyrrho
» Optimistic and Serialized, but few other features
» And did not have quite the right structures

» By 2022, we have less productivity but
» Fully Shareable Data Structures approach
» Triggers, cascades, structured data type
» Big Live Data support, virtual data warehouse

] 2 » Next: Big Live data


https://youtu.be/0YaU59LvgLs

Big Live Data
» If your data originates in lofs of databases
» You could copy the data centrally
» Extract-Transform-Load/Big Data
» But, if it keeps changing this is not good
» Much better to read just what we need now
» And leave data where it is being maintained

» SO suppose our data is remote

» A table’s rows come from different databases
» E.g. Sales or product data from different companies

» The available data is provided as a View
» And accessible using HTTP and JSON

] 3 » Next: A derived table



A derived table

Derived = not actually stored centrally
Columns from D’'s renamed and values probably tfransformed

Dl

D2

D3

(Contributors take responsibility for renaming columns and
transforming data to suit us as their schemas will all be different)
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» Next: Contributing DBMS




Contributing databases

» Contributors provide data in a given form
» Hypertext Transfer Protocol (HTTP) request
» Representational Structure Transfer (REST)
» Java Structured Object Notation (JSON)

» They probably don't have it in this form
» SO, they create a VIEW with the right columns
» Values probably requires some transformation

» Make it available with a given address
» Uniform Resource Locator (URL)
» With access permissions for our view
» Possibly, they might allow some updates
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» Next: Defining contribution



Defining a contribution

» Probably, each conftributor creates a VIEW
» Out of data from one or more actual tables

CREATE VIEW (A,B,C..) AS ....

A B C

Can identify each contributor in the
result view with a conftributor id CID
and maybe other information
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» Next: The central view



Centrally we then have
» A row type CID,..,A,B,C,..

» The local row contains remote data
» A local table T of contributor details, URLS

T' CiD |... URL
DI URL for D1's data

D2 URL for D2's data

D3 URL for D3’'s data
CREATE VIEW V OF (CID..,A,B,C..) AS GET USING T

» OF clause gives V's row type (specifying column data types)
» Includes all columns from T except the last (the URL)
» The remaining columns specify the data from the remote view

17 A

» Next: Dividing responsibilit |
g resp __);3



Division of responsibility

API

HTTP

- = -
’—— - -

View ééhﬁgm’és’ FTTP access

Change request sent to D1,..
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[N N AN D1's API

I D1

No programming!

Views contributed over HTTP transformed
to a common schema

Contributed data remains under D1's
control — D1 retains responsibility

D1 interprets requests for change and
inverts the transformations if it can

» Next: View-mediated access



View-mediated REST access

» A view Info live data (no copying)

[CREATE VIEW sales V
(customer, sales, accSalesShare)
AS SELECT customer, sales,
(SELECT SUM(sales) FROM custSale
WHERE sales »>= u.sales) /
(SELECT SUM(sales) FROM custSale)
FROM custSale AS u]

» Designed for filtering by item
» To discourage retrieval of the entire table

» Next: ABC-Analysis



Example: ABC-Analysis

» Originally, ABC-analysis is a clustering of customers with
regard to their contribution to the sales of a company

» A-customers confribute the most, B is medium, and C-
group customers are least

» The algorithm is defined by 2 threshold values (t1, 12) which
separate A from B and B from C group

» These values are usually 11=50% and 12=85%

Customer accumulS. ... % )
Daimler

Daimler 20000

Bosch 37000 AR%

Siemens 47000 60%

Bosch
Siemens

stikl
stihl 53000 1%

VW 62000 20%
Porsche . 67000

VW
W Porsche

Migros
Migros 71000

ATU
Ford 77700

ATU

Ford

A
A
B
B
B
C
C
C
C

20 » Next: SQL for ABC




Code for ABC-Analysis

» Standard Query Language (SQL)
» With a table custSale(customer, sales)

» Query sales_V and assign a group to each customer according to
its sales percentage ordered by descending sales values.

» [SELECT CASE
WHEN accSalesShare <= 0.5 THEN 'A'
WHEN accSalesShare > 0.5 AND accSalesShare <=0.85 THEN 'B’
WHEN accSalesShare > 0.85 THEN 'C’

ELSE NULL
END as ABC,
customer, sales,

CAST(CAST(sales/(SELECT SUM(sales) FROM sales_V) * 100 as decimal(6,2))

as char(é)) | | ' %" AS share FROM sales_V

ORDER BY sales DESC]

» Result |iABcicu5T0MERism_Es iSHARE i

'|A  |Daimler |20000,00]|25.74

4
IIA |Bosch |17000,00|21.88 %
||B |siemens |1e0e0,00|12.87 %
|B  |stihl |see0,00 |10.30 %
B |V | 7e00,00 |9.01 %

||C |Porsche |5eee,ee |6.44 %
‘|c |Migros |4e@0,00 |5.15 %
llc |ATU |35@0,00 |4.50 %
|c |Ford |3200,00 |4.12 %

2] [--=]-mmmmmm- [----2--- —— | » Next: No query rewriting
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No query rewriting

>
>

Consider the <select list> concept in View

If it contains aggregation functions

> AVG, MAX, MIN, SUM, EVERY, ANY, COUNT, STDEV.., COLLECT, FUSION,
INTERSECTION

During rowset fraversal, rows get added in:

» The resulting rowset has one row per group

» Rows in the source are added in to the result rowset

» Using Registers containing various accumulators, sums, multisets, ..
Now, suppose the view is remote (use REST)

» Sending it to a list of remote contributors

This used to require a lot of analysis and rewriting extra column
names for the remote query

COUNT becomes SUM, AVG needs SUM and COUNT, STDEV
needs sums of squares, collections..

We don’t need to do this any more

» Next: How REST works



What happens with REST

» REST operatfions use standard formats
» For rows, we use JSON documents
» An item for each column of the row

» Why not add some extra columns for
the Registers in that rowe

» ARegister for each occurrence of an
aggregation function in the select list

» We define how to represent a Register in
JSON
23

» Next: an example



A RESTView example

» With several remote sources via POST

» Grouped aggregations are interesting

select sum(e)+char_length(f),f from ww
group by f

>We no longer rewrite it, but send as is:

http:/flocalhost:B188/0B/DE select (SUM{E)+CHAR_LEMGTH{F)),F from t group b
HI TP I-_-_- J0OB /DB
select ibJVitJ—LﬂﬂH_Ltﬂu'1irjj.r from t group by F
Returning ETag: "Z3,-1,188"
--> 4 rows
Response ETag: 23,-1,1E48
http:/flocalhost:B188/0C/DC select (SUM{E)+CHAR_LEMNGTH{(F)),F from u group b
AT TP POST JDLC /DL
select (SUM{E)+CHAR _LENGTH{F)),F from u group by F
:211 Returning ETag: "23,-1,159"

-=» 3 rows
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How does this work?

> E
> 1
> 1

ach database returns its answer
ne data from each has extra fields
ne Regqisters for aggregates by group

> L

npacked and combined by Pyrrho

SQL> select sum(e)+char_length(f),f from ww group by f

|====]====- |
|Cole|F |

|8 | Four |
|11 |Sechs|
|9 |six |
|18 |Three]

o /'\

» Next: The extra fields
A
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Extra Register fields

» The local and remote servers see the same value
expression

» SO the registers are supplied in the left-to-right
ordering

» As a Json document with the following items:
» The string value accumulated by the function if any
» The value of MAX, MIN, FIRST, LAST, ARRAY

> A <|jocumen’r containing numbered fields for a multiset
value

» The value of a typed SUM
» The value of COUNT

> qu)sum of squares (if required for standard deviation
etc

» Next: Example
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This is a simple case

» In this case, there is jJust one hidden field
» The reqister for SUM(E)
» And the values of F don’t overlap ®

» DB returned 4 rows, which conftained
{{"CO].@": 11, "F" "Sechs", "$#9"Z {"9": 6}}}
{{"Col0": 9, "F": "Six", "$#9": {"0": 6}}}

{{"Col0": 8, "F": "Three", "$H#9" : {"0": 3}}}
{{"Col0": 8, "F": "Vier", "$#9": {"0": 4}}}

» DC returned 3 rows

{{"ColO": 11, "F": Ate", "$#9": {"0": 8}}}

{{"CO].@": 9, "F": "FiVE", "$#9": {'@": 5}}}

{{"CO].@": 8, "F": "FOUI"", "$#9"! {"0": 4}}}

» Next: Transactions and REST



Transactions and REST

» All data needs a single transaction master
» Because of the two-army problem
» Transactions start from one database
» Called the local database (i.e. local server)
» There Is no way to address a remote object directly
» Some fields may come from remote views
» Possibly updatable via REST over HTTP1.1 (safe)
» At most one remote update can be allowed
» When the local commit is called
» Local database locked, validation performed
» The single remote update is done via HTTP1.1
» And then the local commit can complete/unlock

28

» Next: Object-Orientation



REST and Object-Orientation

» Pyrrho has a Versioned AP
» Some local base table rows are entities

» Pyrrho generates a Versioned class
» With navigation properties like Java Persistence, LINQ

» Support for versions is built in to the DBMS
» Connections may have different row versions
» A versioned object is always for a particular connection
» Some entity fields may be remote (updatable via REST)
» Versioned class C hAs Get(), put(), Post(), Delete()
» Fetch Versioned objects from a connection:
» C[] Get<C>(w) and variants

» C[] FindAll<C>(), C FindOne<C>(key), C[] FindWith<C>(where)

» Guaranteed fransaction-safe
» Allows long serialized transactions

29

» Next: Other DBMS



Future Work: with other DBMS

» REST for server communication
» Common format (JSON), protocol (HTTP1.1)
» Possibly with ETags (RFC/7232), Registers

» As a non-privileged Internet client
» With privileges allocated in the usual way
» Need adaptation to SQL dialects

» Agreement about transactions
» Simplify distributed problem with RESTView

30

» Next: Conclusions



Conclusions

» This research provides new DBMS tools
» Shareable data structures library

» Serialized fransactions

» Optimistic: no client locking of data
» Better suited to needs of web applications

» Big Live Data implementation
» Providing better real-time owned behavior
» Optimized for aggregations of remote views

» Versioned API| for tfransaction-safe apps
31

» Next: Links



Links

Crowe, M. K., Matalonga, S.: Shareable Data

Structures, on
hitps://aithub.com/MalcolmCrowe/ShareableDatas

fructures

» includes source code for StrongDBMS, PyrrhoV7alpha
and documentation

Crowe, M. K., Laux, F.: Implementing True Serializable
Transactions, Tutorial, DBKDA 2021

» hitps://www.youiube.com/waichev=t4h-zPBPtSw&it=39s
» hittps://www.iaria.org/conferences2021 /filesDBKDA21/

» Version 6.3: hitps://pyrrhodb.uws.ac.uk
» 50 clerks demo: hitps://youiu.be/0YaUsS2Lvals
» Pyrrho blog: hifps://pyrrhodb.blogspof.com

/ \
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» Next: References oo



https://github.com/MalcolmCrowe/ShareableDataStructures
https://www.youtube.com/watch?v=t4h-zPBPtSw&t=39s
https://www.iaria.org/conferences2021/filesDBKDA21/
https://pyrrhodb.uws.ac.uk/
https://youtu.be/0YaU59LvgLs
https://pyrrhodb.blogspot.com/
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